Noviembre 23, 2017, 04:39:21 am

Autor Tema: Iniciarme en Canary  (Leído 3527 veces)

Desconectado Zant

  • zant95
  • Mensajes: 848
  • La red es vasta e infinita
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • znt.se
    • Awards
Iniciarme en Canary
« en: Septiembre 07, 2011, 09:08:10 pm »
Hola a todos, siempre he usado Bukkit para crear servidores, pero viendo como funciona este me está interesando informarme sobre Canary.
He estado buscando plugins y he encontrado pocos y desactualizados, pero como Canary es por así decirlo es la evolución de hmod quería saber si los plugins de este son compatibles.

También me interesaría saber el plugin que usan para detectar a griefers y proteger zonas.

¡Gracias!

Desconectado reddw562

  • reddw562
  • *
  • Mensajes: 3007
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • Awards
Re:Iniciarme en Canary
« Respuesta #1 en: Septiembre 07, 2011, 09:26:07 pm »
Los plugins que hay en el foro de Canary (Enlace web) están actualizados y te indican en qué versión/versiones de Canary funcionan.

Sobre qué plugins hay instalados o no en el server creo que mejor debería hablarlo un admin, pero sí te recomiendo que instales por lo menos el plugin Cuboid, que se usa mucho para edición del terreno y para protección de zonas. Luego el incluir más plugins o no dependerá del uso que le quieras dar al servidor.

Desconectado Zant

  • zant95
  • Mensajes: 848
  • La red es vasta e infinita
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • znt.se
    • Awards
Re:Iniciarme en Canary
« Respuesta #2 en: Septiembre 08, 2011, 12:11:27 am »
Más que Cuboid estaba pensando en WorldEdit, iConomy, algún plugin de chat y el de antigrief de este servidor.

Es que un amigo busca host y como tengo un ordenador sin usar pues he decidido ofrecerle ese como servidor dedicado.

Desconectado Azafran

  • Azafran
  • Mensajes: 231
    • Ver Perfil
    • Azafran Art
    • Awards
Re:Iniciarme en Canary
« Respuesta #3 en: Septiembre 08, 2011, 01:09:47 am »
Una cosa que siempre me he preguntado, y aprovechando el hilo: ¿Por qué Canary y no Bukkit?

Desconectado dB

  • *
  • Mensajes: 4446
  • /restart
    • Ver Perfil
    • Awards
Re:Iniciarme en Canary
« Respuesta #4 en: Septiembre 08, 2011, 01:41:28 am »
Zant, en el foro de 'releases' tienes los plugins actualizados para la última versión de Canary:
http://forums.canarymod.net/forumdisplay.php?fid=12

Tienes WorldEdit (la misma versión que en bukkit), iConomy, varios de chat (aunque ninguno me gusta demasiado), logblock para registrar los cambios en el mapa, worldguard para evitar problemas con el fuego, y un porrón mas.

Una cosa que siempre me he preguntado, y aprovechando el hilo: ¿Por qué Canary y no Bukkit?

En el server siempre se ha intentado mantener al minimo el numero de Plugins instalados y con Canary tienes mas cosas integradas de serie: permisos, ayudas, comandos, lo que te ahorra tener que andar detras de los plugins basicos. Los plugins no solo hay que instalarlos, luego hay que mantenerlos al dia con cada actualización, a mas plugins, mas trabajo.

De momento con Canary tenemos lo que queremos, por eso no se ha cambiado. Si en un futuro (quien sabe, igual con la 1.8 ), el Canary no nos vale, pues nos pasaremos a Bukkit (o a otro).

Desconectado Zant

  • zant95
  • Mensajes: 848
  • La red es vasta e infinita
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • znt.se
    • Awards
Re:Iniciarme en Canary
« Respuesta #5 en: Septiembre 08, 2011, 11:23:52 am »
Muchas gracias por la aclaración dBuxo, ahora mismo el link que me has dado no funciona por razones de mantenimiento de los foros de Canary, pero cuando lo pueda ver me informaré más.

Desconectado Azafran

  • Azafran
  • Mensajes: 231
    • Ver Perfil
    • Azafran Art
    • Awards
Re:Iniciarme en Canary
« Respuesta #6 en: Septiembre 08, 2011, 04:50:47 pm »
En el server siempre se ha intentado mantener al minimo el numero de Plugins instalados y con Canary tienes mas cosas integradas de serie: permisos, ayudas, comandos, lo que te ahorra tener que andar detras de los plugins basicos. Los plugins no solo hay que instalarlos, luego hay que mantenerlos al dia con cada actualización, a mas plugins, mas trabajo.

Entiendo, tiene bastante sentido que sea así  ;).

Desconectado Zant

  • zant95
  • Mensajes: 848
  • La red es vasta e infinita
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • znt.se
    • Awards
Re:Iniciarme en Canary
« Respuesta #7 en: Septiembre 09, 2011, 01:29:56 am »
He estado probando Canary y me ha convencido, aunque exista menos soporte e información, de serie es mucho más configurable que Bukkit y en mi opinión tiene más potencial.

Solo hay una cosa que no me sale, instalar el LogBlock, y es que a parte de meterlo en la carpeta plugins hay que hacer algo más, ya que en el propio post hay un apartado titulado "MySQL table create" con un código y no sé que hacer con él.

http://forums.canarymod.net/?topic=29

Saludos.

Desconectado dB

  • *
  • Mensajes: 4446
  • /restart
    • Ver Perfil
    • Awards
Re:Iniciarme en Canary
« Respuesta #8 en: Septiembre 09, 2011, 01:49:12 am »
Zant, El logblock almacena toda la información de las modificaciones en el mapa en una base de datos mysql, antes de poder usarlo necesitas crear la base de datos con el script que te ponen en el post (se supone que tienes instalado el mysql).


Desconectado Zant

  • zant95
  • Mensajes: 848
  • La red es vasta e infinita
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • znt.se
    • Awards
Re:Iniciarme en Canary
« Respuesta #9 en: Septiembre 09, 2011, 03:04:14 am »
¿Pero donde se supone que debo añadir ese código? Esa es la duda que tengo.
He añadido al final del archivo "minecraft.sql" lo siguiente:

Código: [Seleccionar]
CREATE TABLE `blocks` (
   `id` int(11) NOT NULL AUTO_INCREMENT,
   `date` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
   `player` varchar(32) NOT NULL DEFAULT '-',
   `replaced` int(11) NOT NULL DEFAULT '0',
   `type` int(11) NOT NULL DEFAULT '0',
   `x` int(11) NOT NULL DEFAULT '0',
   `y` int(11) NOT NULL DEFAULT '0',
   `z` int(11) NOT NULL DEFAULT '0',
   PRIMARY KEY (`id`),
   KEY `coords` (`y`,`x`,`z`),
   KEY `type` (`type`),
   KEY `replaced` (`replaced`),
   KEY `player` (`player`)
 );
 CREATE TABLE `extra` (
   `id` int(11) NOT NULL,
   `extra` text,
   PRIMARY KEY (`id`)
 );
 
ALTER TABLE blocks ADD world int(1) DEFAULT '0' NOT NULL AFTER z;

ALTER TABLE blocks ADD INDEX(player);
ALTER TABLE blocks ADD INDEX(type);
ALTER TABLE blocks ADD INDEX(replaced);
Pero aún así me sigue reportando errores al iniciar el servidor.



Por cierto, con el plugin LWC activo el servidor no funciona, sale esto:
Código: [Seleccionar]
[WARNING] Can't keep up! Did the system time change, or is the server overloaded?Lo he bajado de aquí: http://forums.canarymod.net/?topic=22
PD: Ese usuario tiene una firma de Minecrafters y usa tu mismo skin, dBuxo, aunque se llama Talmor ;)

Desconectado reddw562

  • reddw562
  • *
  • Mensajes: 3007
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • Awards
Re:Iniciarme en Canary
« Respuesta #10 en: Septiembre 09, 2011, 03:13:15 am »
Un brazo a que es dBuxo pero con otro nick...

De lo primero que has preguntado no te puedo contestar, pero del segundo mensaje sí. Sale cuando se sobrecarga el servidor y éste empieza a consumir más recursos de los que debería teniendo en cuenta a cuánto puede llegar tu ordenador. Sale mucho si tienes muchos plugins funcionando, si detonas grandes cantidades de TNT, si editas grandes zonas con Cuboid, etc... Pero debería seguir funcionando, aunque más lentamente (lag). ¿No te deja entrar si sale eso o te desactiva el LWC o algo así?

Desconectado dB

  • *
  • Mensajes: 4446
  • /restart
    • Ver Perfil
    • Awards
Re:Iniciarme en Canary
« Respuesta #11 en: Septiembre 09, 2011, 08:55:45 am »


Por cierto, con el plugin LWC activo el servidor no funciona, sale esto:
Código: [Seleccionar]
[WARNING] Can't keep up! Did the system time change, or is the server overloaded?

El warning ese no tiene nada que ver con que funcione o no el LWC, ponme la salida entera de la consola y seguramente veremos la causa.
Es probable que sea porque el LWC se descarga unos ficheros la primera vez que se ejecuta, y por alguna razón en tu server no puede hacerlo.

Si, es raro el tio ese, con mi skin, mi avatar, mi firma y mi pésimo ingles. :D
« Última modificación: Septiembre 09, 2011, 09:34:10 am por dBuxo »

Desconectado Zant

  • zant95
  • Mensajes: 848
  • La red es vasta e infinita
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • znt.se
    • Awards
Re:Iniciarme en Canary
« Respuesta #12 en: Septiembre 09, 2011, 11:20:20 am »
Ese Warning solo sale si activo LWC, no pasa con otros plugins y sale inmediatamente después de iniciar el servidor, lo he probado en un sobremesa de 4gb de ram, así que no creo que tenga nada que ver con la potencia.
He iniciado el servidor con un plugin cada vez y solo sale con LWC.
Os dejo la salida de la terminal con los plugins WorldGuard, WorldEdit, LogBlock y LWC, de los cuales solo me fallan los dos últimos.
Spoiler
Código: [Seleccionar]
151 recipes
16 achievements
09-sep-2011 11:15:40 DeadLockDetector <init>
INFO: CanaryMod: Deadlock Detector Thread initialized.
2011-09-09 11:15:40 [INFO] Starting minecraft server version Beta 1.7.3
2011-09-09 11:15:40 [INFO] Loading properties
2011-09-09 11:15:40 [INFO] Starting Minecraft server on *:25565
2011-09-09 11:15:40 [INFO] Note: your current classpath is: CanaryMod.jar
2011-09-09 11:15:40 [INFO] Canary Build: 8
2011-09-09 11:15:40 [INFO] Preparing level "world"
2011-09-09 11:15:41 [INFO] Preparing start region for level 0
2011-09-09 11:15:42 [INFO] Preparing spawn area: 57%
2011-09-09 11:15:42 [INFO] Preparing start region for level 1
2011-09-09 11:15:42 [INFO] Done (1779966449ns)! For help, type "help" or "?"
2011-09-09 11:15:42 [INFO] CanaryMod: Loading plugins...
2011-09-09 11:15:42 [INFO] WorldGuard version 2.0beta4 loaded
2011-09-09 11:15:42 [INFO] WorldGuard: Blacklist loaded.
2011-09-09 11:15:42 [INFO] WorldGuard: Single session is enforced.
2011-09-09 11:15:42 [INFO] WorldGuard: TNT ignition is blocked.
2011-09-09 11:15:42 [INFO] WorldGuard: Lighters are blocked.
2011-09-09 11:15:42 [INFO] WorldGuard: Lava fire is blocked.
2011-09-09 11:15:42 [INFO] WorldGuard: All fire spread is disabled.
2011-09-09 11:15:42 [INFO] WorldGuard: Your version of hMod appears to support all features.
2011-09-09 11:15:43 [INFO] WorldEdit version 4.7-SNAPSHOT-Canary Beta9 loaded
2011-09-09 11:15:43 [SEVERE] LogBlock SQL exception
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

Last packet sent to the server was 0 ms ago.
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at com.mysql.jdbc.Util.handleNewInstance(Util.java:406)
at com.mysql.jdbc.SQLError.createCommunicationsException(SQLError.java:1074)
at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2103)
at com.mysql.jdbc.ConnectionImpl.<init>(ConnectionImpl.java:718)
at com.mysql.jdbc.JDBC4Connection.<init>(JDBC4Connection.java:46)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at com.mysql.jdbc.Util.handleNewInstance(Util.java:406)
at com.mysql.jdbc.ConnectionImpl.getInstance(ConnectionImpl.java:302)
at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:282)
at java.sql.DriverManager.getConnection(DriverManager.java:582)
at java.sql.DriverManager.getConnection(DriverManager.java:185)
at ConnectionService.getConnection(ConnectionService.java:75)
at JDCConnectionDriver.connect(JDCConnectionDriver.java:39)
at java.sql.DriverManager.getConnection(DriverManager.java:582)
at java.sql.DriverManager.getConnection(DriverManager.java:207)
at LogBlock.getConnection(LogBlock.java:110)
at LogBlock.checkTables(LogBlock.java:118)
at LogBlock.enable(LogBlock.java:64)
at PluginLoader.load(PluginLoader.java:388)
at PluginLoader.loadPlugin(PluginLoader.java:340)
at PluginLoader.loadPlugins(PluginLoader.java:324)
at OChunkProviderServer.a(OChunkProviderServer.java:144)
at OWorld.a(OWorld.java:139)
at OWorld.h(OWorld.java:1526)
at net.minecraft.server.MinecraftServer.h(SourceFile:371)
at net.minecraft.server.MinecraftServer.run(SourceFile:307)
at OThreadServerApplication.run(SourceFile:422)
Caused by: java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
at java.net.Socket.connect(Socket.java:529)
at java.net.Socket.connect(Socket.java:478)
at java.net.Socket.<init>(Socket.java:375)
at java.net.Socket.<init>(Socket.java:218)
at com.mysql.jdbc.StandardSocketFactory.connect(StandardSocketFactory.java:253)
at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:280)
at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2026)
... 27 more
2011-09-09 11:15:43 [SEVERE] LogBlock: errors while loading, check logs for more information.
LWC [1.60] Initializing LWC
LWC [1.60] Binding commands
LWC [1.60] Loaded command : Command_Admin
LWC [1.60] Loaded command : Command_Create
LWC [1.60] Loaded command : Command_Free
LWC [1.60] Loaded command : Command_Info
LWC [1.60] Loaded command : Command_Modes
LWC [1.60] Loaded command : Command_Modify
LWC [1.60] Loaded command : Command_Unlock
Config [1.60] Loaded 5 config entries
LWC [1.60] LWC config:      lwc.properties
LWC [1.60] SQLite jar:      lib/sqlite.jar
LWC [1.60] SQLite library:  lib/linux-amd64.lib
LWC [1.60] DB location:     lwc.db
LWC [1.60] Opening sqlite databases
2011-09-09 11:15:49 [SEVERE] LogBlock v15 is not supported on your version of hMod (8), upgrade to at least hMod 132
PhysDB [1.60] Creating physical tables if needed
MemDB [1.60] Creating memory tables
LWC [1.60] Protections: 0
LWC [1.60] Limits: 0
LWC [1.60] Registering hooks
2011-09-09 11:15:50 [INFO] CanaryMod: Loaded 4 plugins.
2011-09-09 11:15:50 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?

Por cierto, dBuxo, no me has contestado si hice bien al editar el archivo "minecraft.sql".
« Última modificación: Septiembre 09, 2011, 11:22:38 am por zant95 »

Desconectado dB

  • *
  • Mensajes: 4446
  • /restart
    • Ver Perfil
    • Awards
Re:Iniciarme en Canary
« Respuesta #13 en: Septiembre 09, 2011, 11:52:25 am »
El LWC parece que carga bien, no te preocupes por los warnings que te salen.

El logblock es el que te da problemas, te faltan los datos de conexión a la base de datos.

Canary tiene 2 medios principales para almacenar los datos: flatfiles o mysql.
si lo tienes por flatfiles, los datos de usuarios, homes, warps, bans y demas se guardan en los correspondientes ficheros .txt, no tienes que configurar nada.

Si lo tienes por mysql, tienes que preparar un usuario y contraseña para Canary, e importar el minecraft.sql con alguna herramienta (por linea de comandos o con phpmyadmin).

Aparte de esto, el logblock también tiene acceso a BD mysql, puedes configurarle la misma BD que al Canary, o crear una nueva. Lo mismo con el usuario.

 Resumiendo: Para Canary el mysql es opcional, para el logblock no.

Desconectado Zant

  • zant95
  • Mensajes: 848
  • La red es vasta e infinita
  • Awards Miembro del Gremio de Constructores
    • Ver Perfil
    • znt.se
    • Awards
Re:Iniciarme en Canary
« Respuesta #14 en: Septiembre 09, 2011, 12:35:02 pm »
No tengo mucha experiencia manejando bases de datos ¿podrías detallarme más lo que tengo que hacer?
Sobre como configurar la base de datos de Canary me refiero.
¿Cada vez que inicie el servidor tengo que importar la base de datos o es algo que solo se hace una vez?