Agosto 24, 2017, 10:46:37 am

Autor Tema: Problema rarisimooo !  (Leído 3245 veces)

Desconectado Saww

  • Saww1992
  • Mensajes: 17
    • Ver Perfil
    • Awards
Problema rarisimooo !
« en: Noviembre 16, 2012, 01:52:26 pm »
Buenas tengo un problema raro pero raro raro. Si inicio el exe. del server para iniciar mi server que tengo para jugar con un amigo   luego el launcher del minecraft no se abre. Al revés también me pasa si inicio primero el launcher del minecraft  el archivo del server.exe no se abre y no puedo crear . Es un problema muy raro. He desinstalado y vuelto aa actualizar java, he actualizado la tarjeta gráfica, descargado otro launcher... Una ayuda por favor

Desconectado Spirion

  • Spirion
  • *
  • Mensajes: 4094
  • Chipirones para todos! :)
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #1 en: Noviembre 16, 2012, 02:06:43 pm »
No entiendo el párrafo...

Desconectado Saww

  • Saww1992
  • Mensajes: 17
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #2 en: Noviembre 16, 2012, 03:06:06 pm »
Haber para poder jugar ocn mi amigo tengo que ejecutar el archivo del server, es decir, el archivo server.es Luego para entrar a jugar tengo que iniciar el launcher del minecraft no? Pues solo puedo iniciar uno de los 2 pero si tengo iniciado uno el otro no se abre.

Iverson383

Re:Problema rarisimooo !
« Respuesta #3 en: Noviembre 16, 2012, 03:07:58 pm »
Si es un servidor vanilla con una sola persona es más efectivo usar hamachi...

Desconectado Dennver

  • Dennver
  • *
  • Mensajes: 149
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #4 en: Noviembre 16, 2012, 03:19:21 pm »
@Spirion
Que no puede iniciar su servidor y el Minecraft a la vez, vamos.
___

La verdad no tengo ni idea de servidores, pero ¿No te sale ningún tipo de error al ejecutar Minecraft con el servidor abierto?
Si es así tal vez alguien pueda ayudarte, si no...difícil lo veo :S
BRB

Conectado robertoccu

  • robertoccu
  • *
  • Mensajes: 9129
    • Ver Perfil
    • CCUcraft - Youtube
    • Awards
Re:Problema rarisimooo !
« Respuesta #5 en: Noviembre 16, 2012, 03:20:26 pm »
Usa el .jar para el servidor en vez del .exe, a ver si asi...

Desconectado youss

  • *
  • Mensajes: 1542
  • Awards
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #6 en: Noviembre 16, 2012, 03:23:38 pm »
Si es un servidor vanilla con una sola persona es más efectivo usar hamachi...
El hamachi es un asco, no se ni para qué lo usan, la verdad...


Saww, puede ser problema de que el minecraft y el server.exe ejecuten el mismo archivo de java.
Apare, en el 99% de los casos cuando ejecutas el server.exe funciona pero no se ve, es una aplicación sin pantalla, y lo mejor es ponerle la extensión .bat, para controlarlo.

Para hacerlo, haz esto(bukkit):




Crear bloc de notas. Nombrarlo como start.txt.

Dentro pones:

@echo off
java -Xincgc -Xmx1024M -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:ParallelGCThreads=2 -XX:+AggressiveOpts -jar (aquisinparentesisremarcastodoelconjuntoypegaselnombredelarchivo.jar)
pause



Luego cambiar el nombre a start.bat y extensión all files.

Luego, al ejecutarlo ya podrás verlo.


Aquí, te dejo mi pequeño video.

Spoiler

Desconectado Saww

  • Saww1992
  • Mensajes: 17
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #7 en: Noviembre 16, 2012, 04:10:04 pm »
Si si que veía el server funcionando. Puede que sea lo del java que dices pero he encontrado una forma más fácil de hacerlo. Primero inicio el server y luego uso el launcher ese en el que puedes  iniciar minecraft con la versión que quieras pues lo inicio con la versión que tengo, es decir desde el .jar ese directo y ya me funciona. Por si a alguien le pasa lo mismo que a mi que haga eso que funciona. Gracias por vuestras respuestas

Desconectado Saww

  • Saww1992
  • Mensajes: 17
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #8 en: Noviembre 17, 2012, 12:15:38 pm »
El metodo que he dicho funciona pero da mucho lag. Voy a probar lo que me habeis dicho que aunque a priori parece más complicado  podre jugar con el launcher bueno y solucionare el lag.

Creo que mi problema es que utilizan el mismo archivo de java como dices. eso como se puede solucionar ?
( Es un server que usamos yo  y un amigo más aunque a veces llegamos a jugar 4 personas en total como máximo y usamos hamachi
« Última modificación: Noviembre 17, 2012, 12:20:28 pm por Saww »

Desconectado youss

  • *
  • Mensajes: 1542
  • Awards
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #9 en: Noviembre 17, 2012, 01:08:47 pm »
El metodo que he dicho funciona pero da mucho lag. Voy a probar lo que me habeis dicho que aunque a priori parece más complicado  podre jugar con el launcher bueno y solucionare el lag.

Creo que mi problema es que utilizan el mismo archivo de java como dices. eso como se puede solucionar ?
( Es un server que usamos yo  y un amigo más aunque a veces llegamos a jugar 4 personas en total como máximo y usamos hamachi

Para no inundar el foro, si quieres me das tu correo o me envias mensajes por el foro.

Para comenzar, olvídate del hamachi. El hamachi solo sirve si no tienes habilidad para abrir ports y demás, y lo complica todo.
Si, para cambiar de uso el archivo java, puedes configurarlo, es bastante largo, te lo explico detallado por privado si quieres.

El archivo .bat suele dar menos lag, y se ejecuta en comando cmd, lo cual es mejor que abrirlo directamente en java, que gasta más recursos de ram del ordenador.

Spoiler

Desconectado hostthegame

  • Mensajes: 7
    • Ver Perfil
    • Awards
Re:Problema rarisimooo !
« Respuesta #10 en: Noviembre 23, 2012, 08:53:38 pm »
ey men por lo que e estado viendo los posts y todo lo que han puesto creo que seria ueno que intentaras lo que te esta diciendo youssef_96_96 porque se ve que sabe sobre esto de los servido res y pues si te puede ayudar mucho lo que el te esta diciendo intentalo y veras que te saldra bien
muchas gracias,
Hostthegame.  :)