Agosto 23, 2017, 07:40:11 pm

Autor Tema: Problemas al teleportarse  (Leído 335 veces)

Desconectado LucasK336

  • LucasK336
  • *
  • Mensajes: 2052
  • Rascacielífico empedernido
    • Ver Perfil
    • Awards
Problemas al teleportarse
« en: Febrero 22, 2014, 01:29:48 am »
Si bien se que probablemente no sea "culpa" del server, solo quiero comentar que últimamente me está llevando bastante tiempo reaccionar tras conectarme al server, hacer /home o /spawn.

Básicamente hago (por ejemplo) /home, me teletransporto, aparece el mensaje usual "Teletransportándote a tu home actual", pero tras esto, aunque soy capaz de moverme libremente, el chat se congela (ya no se reciben mensajes) y durante al menos un minuto no puedo hacer nada, ya que a cada rato me "patea" de nuevo al punto al que me he teletransportado. Los cofres no se abren, al escribir /tps o /ping no recibo respuesta, los botones y palancas puedo moveras pero no hacen nada, puedo picar y romper pero no salta el objeto picado, el sol se "atasca" en el cielo... y pasado ese minuto de repente ocurre todo lo que he hecho durante ese tiempo. Me entran de repente todos los mensajes del chat que me tendrían que haber llegado, se activan los mecanismos cuyo botones y/o palancas he tocado, se me abren los cofres, etc.

La verdad es un poco irritante, aunque mal que mal puedo vivir con ello. Se que esto no tiene mucho que ver seguramente con el servidor, y también se que no soy el único experimentándolo (creo que a ichi también le pasa). Al menos me gustaría dejar constancia de que esto ocurre.
« Última modificación: Febrero 22, 2014, 01:31:58 am por LucasK336 »

Desconectado Titi_Riera

  • Titi_Riera
  • *
  • Mensajes: 608
  • Awards Completó todos los retos del Mapa 1.6
    • Ver Perfil
    • Awards
Re:Problemas al teleportarse
« Respuesta #1 en: Febrero 22, 2014, 03:28:00 am »
Si bien se que probablemente no sea "culpa" del server, solo quiero comentar que últimamente me está llevando bastante tiempo reaccionar tras conectarme al server, hacer /home o /spawn.

Básicamente hago (por ejemplo) /home, me teletransporto, aparece el mensaje usual "Teletransportándote a tu home actual", pero tras esto, aunque soy capaz de moverme libremente, el chat se congela (ya no se reciben mensajes) y durante al menos un minuto no puedo hacer nada, ya que a cada rato me "patea" de nuevo al punto al que me he teletransportado. Los cofres no se abren, al escribir /tps o /ping no recibo respuesta, los botones y palancas puedo moveras pero no hacen nada, puedo picar y romper pero no salta el objeto picado, el sol se "atasca" en el cielo... y pasado ese minuto de repente ocurre todo lo que he hecho durante ese tiempo. Me entran de repente todos los mensajes del chat que me tendrían que haber llegado, se activan los mecanismos cuyo botones y/o palancas he tocado, se me abren los cofres, etc.

La verdad es un poco irritante, aunque mal que mal puedo vivir con ello. Se que esto no tiene mucho que ver seguramente con el servidor, y también se que no soy el único experimentándolo (creo que a ichi también le pasa). Al menos me gustaría dejar constancia de que esto ocurre.

Suscribo punto por punto. No siempre pero muy a menudo.

Desconectado dB

  • *
  • Mensajes: 4446
  • /restart
    • Ver Perfil
    • Awards
Re:Problemas al teleportarse
« Respuesta #2 en: Febrero 22, 2014, 09:09:31 am »
¿Puedes indicarme fecha y hora de alguna vez que haya pasado?  Para comprobar los logs por si hay algo raro.
¿Te pasa siempre?
¿con mods o sin mods? (Si es con mods prueba en vanilla para descartar cosas)

Lo que más me sorprende no es que no te deje interactuar, sino que luego lo haga todo de golpe.

Cuando te pasa ¿puedes hablar normalmente por el chat?

Enviado desde mi GT-I9300 usando Tapatalk 2


Desconectado LucasK336

  • LucasK336
  • *
  • Mensajes: 2052
  • Rascacielífico empedernido
    • Ver Perfil
    • Awards
Re:Problemas al teleportarse
« Respuesta #3 en: Febrero 22, 2014, 09:06:19 pm »
Perdón por tardar en responder, vi que lo que había escrito había desaparecido y no me explicaba como hasta que encontré este tema.

A ver, pasar me ha pasado ya antes, hay ocasiones en las que deja de ocurrir durante varios días o semanas (me teletransporto y puedo inmediatamente actuar y el chat responde instantáneamente), y luego empieza a ocurrir de nuevo. Ahora mismo justamente, me he metido en el foro para hacer algo durante ese minuto que tengo que esperar tras haber hecho /home.

He probado con y sin mods (tengo el Zyin's HUD instalado y el Too Many Items para sp) pero pasa de la misma manera.

Y si, lo hace todo de golpe, o al menos eso es lo que yo (como "client") veo que ocurre, pero creo que no ocurre todo de golpe para el server, o hay cosas que para el server simplemente no ocurren. Si yo por ejemplo intento picar toda una superficie durante ese minuto, puedo ir rompiendo los bloques (aunque los items no saltan), y a veces cuando veo que todo comienza a funcionar con normalidad (el chat empieza a ir bien, etc) los bloques no reaparecen, si no que siguen picados. Pero no puedo atravezar el volúmen donde estaban (me echa para atrás), si coloco nuevos bloques en donde estaban estos se convierten ante mis ojos en los bloques originales, y finalmente si salgo y vuelvo a entrar descubro que en realidad nunca he picado nada y, todo sigue exactamente igual.

Para explicarme mejor he hecho un pequeño gif demostrando más o menos un ejemplo lo que pasa. Se ve como tras hacer /spawn puedo picar sin problemas, caidas enormes sin hacerme daño, y como al final es como que todo empieza a funcionar bien, entran todos los mensajes del chat de repente (incluso los que yo he escrito), etc. Como ya dije esto también pasa con cofres que intento abrir y mecanismos de redstone que intento activar. Si hago un salto muy grande y luego sigo caminando, a veces recibo el daño un tiempo después (en este caso no muero de la caida porque he atravezado bloques que en realidad no debería haber atravezado)



Gracias por la anteción  ;)

Fochis

Re:Problemas al teleportarse
« Respuesta #4 en: Febrero 22, 2014, 09:21:41 pm »
Por si es de utilidad. Es lo mismo que le pasa a Nitro_Poison en el FTB (y a mi también). Puedes hacer de todo pero el server no se da por enterado, hasta que sincroniza y entonces hace todo de golpe.

FTB Problema de lag